Back to overview
Downtime

Downtime due to upgrading the community forum

Apr 03 at 03:50pm UTC
Affected services
Nomad Gate community forum

Resolved
Apr 03 at 04:00pm UTC

All systems are up and running again!

Created
Apr 03 at 03:50pm UTC

The forum is currently unavailable due to upgrades. I hope to have everything up and running again shortly.