Back to overview
Downtime

Forum unavailable

Mar 16 at 05:31pm UTC
Affected services
Nomad Gate community forum

Resolved
Mar 16 at 06:58pm UTC

The issue affecting the forum has been resolved and it's back online again. Thank you for your patience!

Created
Mar 16 at 05:31pm UTC

The forum is experiencing downtime following a failed software update. Currently working on a fix!