Back to overview
Resolved
Forum upgrade in progress
Aug 26, 2026 at 7:39pm UTC
Affected services
Nomad Gate community forum
Resolved
Aug 26, 2026 at 8:24pm UTC
It took a bit longer than expected, but we're back online now.
Affected services
Created
Aug 26, 2026 at 7:39pm UTC
We'll be back shortly!
Affected services